2012年8月2日木曜日

Linux Mintでgem update

VMWare Player上のLinux Mintにruby入れてgemを更新しようとすると、Cannot load zlibと出る。

なんか調べたらUbuntu系+Ruby 1.9ではメジャーな現象らしい。

apt-get install zlib1g-dev

で、gem update --system

今度はopensslがない、と怒られる。ここで、openssl入れるのに相当手間取る。CentOS系ではほとんどつまずかないので、ある意味新鮮w

さらにGoogle先生に聞いたら

http://www.codeweavers.com/support/forums/general/?t=26;msg=128749

ということなので、

sudo apt-get updateして

sudo apt-get install libcurl4-openssl-dev libssl-dev

cd /usr/local/src/ruby.../ext/openssl

ruby extconf.rb

make

sudo make install

無事、gem update --system --http-proxy http://proxy-server:8080/

で、何のためにgemを更新しようとしたか忘れたw

0 件のコメント:

コメントを投稿